Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
jneyens  
#1 Posted : Monday, September 29, 2014 12:39:36 AM(UTC)
jneyens

Rank: Member

Groups: Member
Joined: 7/12/2007(UTC)
Posts: 8

Thanks: 2 times
I have just updated the Image Upload Suite in our ASP.NET v4.5 (C#, WebForms) application to 8.1.5.

We use these options in codebehind:

Code:
imageUploader.AutoSave = false;
imageUploader.PaneLayout = PaneLayoutMode.ThreePanes;
imageUploader.EnableAutoRotation = true;
imageUploader.EnableRotation = true;
imageUploader.EnableContextMenu = true;
imageUploader.EnableCheckByClick = true;
imageUploader.EnableDescriptionEditor = false;
imageUploader.EnableImageEditor = false;
imageUploader.EnableUploadPane = true;
imageUploader.EnableUploadProgress = true;


These settings worked fine in the previous version of the uploader (8.0.something), but in 8.1.5 (and 8.0.98), they don't work in the ActiveX version in Internet Explorer 11. They work fine in the Java version in Chrome.

When I hover over the image in the ActiveX version, I get three icons: rotate, edit image and edit description, even though the final two are disabled. In the Java version I only get the rotate icon.

When I view the rendered HTML and JavaScript in IE 11, the options are being set:

Code:
enableAutoRotation: true, enableCheckByClick: true, enableDescriptionEditor: false, enableImageEditor: false


When I try to upload an image I get "Page to upload is inaccessible". In the Java version this works fine as well.

These are all things that were working in the previous version (8.0.something) in both ActiveX and Java.

What could be the problem here?

Update:
I have recovered the previous version from source control. This 8.0.33 and I just noticed IE11 uses the Java version instead of the ActiveX version in v8.0.33.

Edited by user Monday, September 29, 2014 12:50:02 AM(UTC)  | Reason: Not specified

Andrew  
#2 Posted : Wednesday, October 8, 2014 2:45:02 AM(UTC)
Andrew

Rank: Advanced Member

Groups: Member, Administration
Joined: 8/2/2003(UTC)
Posts: 870

Thanks: 2 times
Was thanked: 26 time(s) in 26 post(s)
The reason of the problem is Enhanced Protection Mode in IE. In the next update we will make it EPM compatible. Meanwhile you can try to turn it off in Internet Options -> Advanced tab -> Security group -> uncheck Enable Enhanced Protection Mode* (may require restarting the computer).
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.