Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
handy  
#1 Posted : Tuesday, August 29, 2006 6:51:39 PM(UTC)
handy

Rank: Member

Groups: Member
Joined: 8/29/2006(UTC)
Posts: 2

In my asp code: when i call the method (LoadFromFile FILENAME) -- the FILENAME is in the network (hence FILENAME = "\\ipAddress\folder\FileName"), why it uses 'ServerName' as the username when it tries to connect to that network?
and not the IIS setting default username?
Please kindly help.
Andrew  
#2 Posted : Wednesday, August 30, 2006 6:25:11 PM(UTC)
Andrew

Rank: Advanced Member

Groups: Member, Administration
Joined: 8/2/2003(UTC)
Posts: 866

Thanks: 2 times
Was thanked: 26 time(s) in 26 post(s)
Media Processor does not control under which account it is loaded. Files are accesses with very account the ASP page is executed under.
handy  
#3 Posted : Thursday, August 31, 2006 11:54:49 AM(UTC)
handy

Rank: Member

Groups: Member
Joined: 8/29/2006(UTC)
Posts: 2

that is what baffled me. By right the Media Processor should use the default account that the ASP is executed under. I did a test page today (running on Server 2):

Code:
Dim ServerPath
ServerPath = "\\x.x.x.x\Z"      'Server 1

'Part 1
Dim objFSO
Set objFSO = Server.CreateObject("Scripting.FileSystemObject")
Dim objTextStream
Set objTextStream = bjFSO.OpenTextFile(ServerPath & "\abc.txt", 1)
Response.Write objTextStream.ReadAll
objTextStream.Close
Set objTextStream = Nothing
Set objFSO = Nothing

'Part 2
VideoPath = ServerPath & "\abc.wmv"
Set objMediaProcessor = Server.CreateObject("COMobjectsNET.MediaProcessor")
objMediaProcessor.LoadFromFile VideoPath
Response.Write "<br>" & objMediaProcessor.Width



Then i go to Server1 and check the event logs for login. it shows 2 login (the default asp username account, and the Server2 name!!!). The above code is in one ASP page.
If i just use Part 1 code, the logs shows 1 login (default asp account).
But when i use Part 2 code, the logs shows 2 login (default asp acc and Server2 name).

I did a full test on this. My findings are wierd:
1. When loading a picture (.jpg), MediaProcessor is using the default asp account
2. When loading a 3gp video, MediaProcessor is also using the default asp account.
3. BUT when loading a wmv video, MediaProcessor is using default AND Server2 name to access the file!!!!

Please kindly help.

Edited by user Wednesday, December 19, 2007 2:57:17 PM(UTC)  | Reason: Not specified

Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.