Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
xiaomantoularry  
#1 Posted : Tuesday, August 29, 2006 12:50:18 PM(UTC)
xiaomantoularry

Rank: Member

Groups: Member
Joined: 8/28/2006(UTC)
Posts: 11

Code:
Java(TM) Plug-in: Version 1.4.2_03
Using JRE version 1.4.2_03 Java HotSpot(TM) Client VM
User home directory = C:\Documents and Settings\user1

Proxy Configuration: Browser Proxy Configuration


ImageUploader version: 2.0.50

Current document URL: http://localhost/tmp/BasicDemo/index.php

Reading cookies

Reading referer

Referer: http://localhost/tmp/BasicDemo/index.php

Reading additional form content

Uploading to http://localhost/tmp/BasicDemo/upload.php

java.lang.NoSuchMethodError: java.lang.String.replace(Ljava/lang/CharSequence;Ljava/lang/CharSequence;)Ljava/lang/String;

	at com.aurigma.imageuploader.tools.i.a(Unknown Source)

	at com.aurigma.imageuploader.upload.b.a(Unknown Source)

	at com.aurigma.imageuploader.upload.b.b(Unknown Source)

	at com.aurigma.imageuploader.upload.b.run(Unknown Source)

	at java.lang.Thread.run(Unknown Source)

Edited by user Wednesday, December 19, 2007 2:59:28 PM(UTC)  | Reason: Not specified

xiaomantoularry  
#2 Posted : Tuesday, August 29, 2006 2:53:42 PM(UTC)
xiaomantoularry

Rank: Member

Groups: Member
Joined: 8/28/2006(UTC)
Posts: 11

once i change the JRE to 1.5.0.8 (the latest JRE1.5) and it is working fine - no more exceptions!!

xiaomantoularry  
#3 Posted : Thursday, August 31, 2006 7:23:07 AM(UTC)
xiaomantoularry

Rank: Member

Groups: Member
Joined: 8/28/2006(UTC)
Posts: 11

seems like the jar file from DUAL 4.0 does NOT work with any JRE1.4.2.x version.

how can we enforce the user to install a specific JRE version (say JRE 1.5.0.8) in this case?

please help.
Alex Makhov  
#4 Posted : Thursday, August 31, 2006 8:57:49 PM(UTC)
Alex Makhov

Rank: Advanced Member

Groups:
Joined: 8/3/2003(UTC)
Posts: 998

Hello,

1) Image Uploader works on JRE 1.4.2_06 and later.
2) If you really want to make your users to upload JRE 1.5 you have to change iuembed.js script. There are two different lines of code in it which you should change. Find the strings with something like "java.sun.com" and change it.

Edited by user Tuesday, February 19, 2008 1:33:26 PM(UTC)  | Reason: Not specified

Sincerely yours,
Alex Makhov

UserPostedImage Follow Aurigma on Twitter!
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.