Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
jmarcv  
#1 Posted : Thursday, June 26, 2014 1:04:58 PM(UTC)
jmarcv

Rank: Member

Groups: Member
Joined: 2/6/2012(UTC)
Posts: 27

Thanks: 1 times
I read the FAQ and it says the issue is with php 5.3 with magic_quotes_gpc set on.

Well I recently upgraded 3 servers to PHP 5.4 where magic_quotes_gpc is Off and NOW my images are corrupted where before, in php 5.3, they were fine.

Any suggestions?
Version: AUR_8.0.96-html|flash
Andrew  
#2 Posted : Friday, June 27, 2014 1:10:10 AM(UTC)
Andrew

Rank: Advanced Member

Groups: Member, Administration
Joined: 8/2/2003(UTC)
Posts: 870

Thanks: 2 times
Was thanked: 26 time(s) in 26 post(s)
As far as I remember, this param is no longer available in 5.4 and later (it is always off). So it does not look like it is a problem of the character escaping.

1. Does it affect only thumbnails or the source files are corrupted as well?
2. Does it affect both HTML5 and Flash or only Flash?
3. Could you please send an example of the correct and corrupted image (preferable the same image created with the same uploader - e.g. through PHP 5.3 and PHP 5.4)?
4. It would also help if you send your php.ini settings (you can display them on the page using <?php phpinfo(); ?>).

Perhaps it makes sense to open a support ticket regarding this.
jmarcv  
#3 Posted : Wednesday, July 2, 2014 8:57:11 AM(UTC)
jmarcv

Rank: Member

Groups: Member
Joined: 2/6/2012(UTC)
Posts: 27

Thanks: 1 times
1. I only use thumbnails.
2. HTML5 is fine
3. I no longer have a 5.4 server
4. probably best if I need to escalate to support.

My fix was to roll back PHP for now. However - I am finding this to be innacurate:

http://forums.aurigma.co...corrupted.aspx#post17596
Solution
"You should disable Magic Quotes. To do it, set magic_quotes_gpc directive in your php.ini file to Off."

In fact, one server using 5.28 was STILL corrupting uploads.
Doing a 'diff' on the phpinfo I found that the server that worked had magic_quotes_gpc On
The server corrupting had magic_quotes_gpc Off

I turned magic_quotes_gpc back on for the affected server abd uploads were now normal.

So does your FAQ have a typo?

Edited by user Wednesday, July 2, 2014 8:58:17 AM(UTC)  | Reason: Not specified

Andrew  
#4 Posted : Friday, September 12, 2014 7:07:17 AM(UTC)
Andrew

Rank: Advanced Member

Groups: Member, Administration
Joined: 8/2/2003(UTC)
Posts: 870

Thanks: 2 times
Was thanked: 26 time(s) in 26 post(s)
Are you using $_FILES collection instead of UploadHandler.php? If so, you should pre-process the POST request using the flashrequestfix.php as explained here:

http://www.aurigma.com/docs/us8...f.htm#parsingPostRequest
jmarcv  
#5 Posted : Saturday, October 15, 2016 1:44:23 PM(UTC)
jmarcv

Rank: Member

Groups: Member
Joined: 2/6/2012(UTC)
Posts: 27

Thanks: 1 times
I don't see flashrequestfix.php in 8.5.55
Where can I get it?
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.