Welcome Guest! You need to login or register to make posts.

Notification

Icon
Error

Options
Go to last post Go to first unread
chithra  
#1 Posted : Thursday, September 19, 2019 9:42:53 AM(UTC)
chithra

Rank: Newbie

Groups: Member
Joined: 9/19/2019(UTC)
Posts: 4

I am trying to load the UI framework and things are not going well.

I have passed all the required configs and have added the iframe api as well. Still I am getting the error

Failed to perform an action on Customer's Canvas. Error: "IFrame Api is unable to find location of Customer’s Canvas application. Please make sure you have added id="CcIframeApiScript" to the <script> tag loading IFrame Api:
<head>

<script id="CcIframeApiScript" type="text/javascript" src="http://example.com/CustomersCanvas/Resources/SPEditor/Scripts/IFrame/IframeApi.js"></script>

</head>
For more information please visit https://customerscanvas....i-introduction.htm"
n https://h.customerscanva...ts/IFrame/IframeApi.js:1
loadEditor https://h.customerscanva...ts/IFrame/IframeApi.js:1
framework 3.8.0/dist/imports/es8/dynamic.au-widget-canvas.js:1
framework 3.8.0/dist/imports/es8/dynamic.au-widget-canvas.js:1
dynamic.au-widget-canvas.js:1:27590
Screenshot from 2019-09-19 22-50-46.pngScreenshot from 2019-09-19 22-53-42.png
Sergey_f  
#2 Posted : Sunday, September 22, 2019 8:25:31 PM(UTC)
Sergey_f

Rank: Member

Groups: Member, Moderator
Joined: 12/7/2018(UTC)
Posts: 10

Hello chithra,

Please, provide your Customer's Canvas version, UI Framework version and the config.json file of this product.
What e-commerce platform do you use?

Regards,
Sergey
chithra  
#3 Posted : Sunday, September 22, 2019 9:32:12 PM(UTC)
chithra

Rank: Newbie

Groups: Member
Joined: 9/19/2019(UTC)
Posts: 4

Hello,

Thanks for replying

I am using Drupal commerce (Drupal 7).
I am not sure how to check the versions, but the below js are referred, hence I assuming 3.8.0 version of ui framework.

https://cdn.jsdelivr.net/npm/@aurigma/ui-framework@3.8.0/dist/driver",
"https://cdn.jsdelivr.net/npm/@aurigma/ui-framework@3.8.0/dist/editor",

Attaching the config.json.

Thanks,
Chithra. config.zip (2kb) downloaded 1 time(s).
Sergey_f  
#4 Posted : Sunday, September 22, 2019 10:16:04 PM(UTC)
Sergey_f

Rank: Member

Groups: Member, Moderator
Joined: 12/7/2018(UTC)
Posts: 10

chithra,

Could you give the link where the issue can be reproduced?
If you can't give it public, you can create the case:
https://customerscanvas.com/account/cases

BTW, the links you provided aren't available

Regards,
Sergey

Edited by user Sunday, September 22, 2019 10:30:56 PM(UTC)  | Reason: Not specified

chithra  
#5 Posted : Sunday, September 22, 2019 10:38:23 PM(UTC)
chithra

Rank: Newbie

Groups: Member
Joined: 9/19/2019(UTC)
Posts: 4

Hi,

Below are the valid links to the js files.

https://cdn.jsdelivr.net/npm/@aurigma/ui-framework@3.8.0/dist/driver.js
https://cdn.jsdelivr.net/npm/@aurigma/ui-framework@3.8.0/dist/editor.js
https://h.customerscanva...ipts/IFrame/IframeApi.js

Regards,
Chithra
Sergey_f  
#6 Posted : Sunday, September 22, 2019 11:04:05 PM(UTC)
Sergey_f

Rank: Member

Groups: Member, Moderator
Joined: 12/7/2018(UTC)
Posts: 10

Thank you for the links, we'll check your config.

To check your Customer's Canvas version, run "CustomersCanvas.VERSION" in the console of your browser for the tab with CC design editor.

Regards,
Sergey

Edited by user Sunday, September 22, 2019 11:55:53 PM(UTC)  | Reason: Not specified

chithra  
#7 Posted : Monday, September 23, 2019 2:50:13 AM(UTC)
chithra

Rank: Newbie

Groups: Member
Joined: 9/19/2019(UTC)
Posts: 4

Hi ,

CustomersCanvas.VERSION : "4.4.2"

This is the CC version.
Sergey_f  
#8 Posted : Tuesday, September 24, 2019 4:14:05 AM(UTC)
Sergey_f

Rank: Member

Groups: Member, Moderator
Joined: 12/7/2018(UTC)
Posts: 10

Hello Chithra,

We are working on your issue, I'll keep you posted.

Regards,
Sergey
Sergey_f  
#9 Posted : Wednesday, September 25, 2019 11:03:46 PM(UTC)
Sergey_f

Rank: Member

Groups: Member, Moderator
Joined: 12/7/2018(UTC)
Posts: 10

Hello Chithra,

Apparently, the issue is in the version compatibility.
Try to use the latest version of UI-Framework 4.5.1:
https://www.npmjs.com/package/@aurigma/ui-framework

Regards,
Sergey

Edited by user Wednesday, September 25, 2019 11:04:27 PM(UTC)  | Reason: Not specified

Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.